Error loading RootDSE entry from 10.162.3.155:7001.

General Discussion about LDAP Administrator

Moderator: Support

Error loading RootDSE entry from 10.162.3.155:7001.

Postby anand219 » Mon Jul 02, 2007 6:43 pm

Hi,

I have some trouble connecting my weblogic 10.0 embedded LDAP server using LDAPAdministrator v3.4 ( trial downloaded today ).
The program fails to connect with the following errors:

1. Schema Failed. An error has occurred while loading the RootDSE entry from 10.162.3.155:7001. The default schema entry could not be loaded due to inability to access the RootDSE entry. Further processing will be aborted. Try changing your credentials or the server side access control list (ACL).
2. Generally this is also followed by a Timeout / LocalError in the explorer tree window.
3. An "Error Loading RootDSE" in the Message window.

I tweaked the configuration of the LDAP server to enable anonymous access and put most of the directory in read mode for everybody.

I tried to connect without success using the credentials
1. cn=Admin (directory admin)
2. another user
3. anonymous
and using various "Base DN"

I'm new to LDAP Server Administration ( it is just a test server for development ) so I cannot tell you much more than that.

The funny/sad thing is that everything is fine (even without any configuration tweak) using the free LDAPBrowser 2.6 from this company.
Everything is also fine in both browsing and editing using JXplorer 3.1 (http://www.jxplorer.org/) and LDAPBrowser 2.8beta2 (http://www-unix.mcs.anl.gov/~gawor/ldap/)

I suppose there is a magic switch somewhere that I forgot to enable. Does somebody has any idea ?

( Also, don't know if that's important but the application has no access to internet, only the LAN )

I THINK I HAVE PROBABLY TRIED EVERYTHING OUT..U GUYS ARE MY LAST HOPE...PLEASE DO REPLY...

Thanks.
you can send the reply to anand.sharmaa@gmail.com, if you wish..
anand219
 
Posts: 2
Joined: Mon Jul 02, 2007 6:34 pm

Postby Support » Tue Jul 03, 2007 12:22 pm

Unfortunately, there is no "magic switch".

The difference between LDAP Browser/Administrator 2.X and LDAP Administrator 3.X is that they work on top of different LDAP APIs. For version 2.X we used Netscape LDAP runtime and since version 3.X we've switched to native MS runtime.

It looks like an interoperability issue. We've been reported a couple of times about similar problems with a previous version of BEA and it looks like they were solved with help of BEA's support.

We can start digging into the issue (if you don't mind). Can you please make a dump of the network exchange between LDAP Administrator and BEA's server? It's quite easy with a tool like WireShark.
Support
 
Posts: 886
Joined: Sun Aug 12, 2001 12:00 am

Postby anand219 » Tue Jul 03, 2007 10:00 pm

hey thnx for the reply...
i did download wireshark0.99.5 for vista but i cudnt really figure out how do i go ahead with it..
as the ldap browser/admin 3.4 is installed on my windows vista machine and the weblogic server 10.0 is on the hpux machine..i dont know how to track it down..never used this stuff before..can u please explain me in detail how do i goo about it...
i get connected via the wireless access or the ethernet..
kindly detail me the steps and what you want me to exactly..
thanks.
anand219
 
Posts: 2
Joined: Mon Jul 02, 2007 6:34 pm

Postby Support » Mon Jul 09, 2007 8:09 am

1) Run Wireshark
2) Configure an interface to capture data on (Edit->Preference->Capture)
3) Run LDAP Administrator
4) Using Wireshark run capture (Capture->Start)
5) Using LDAP Administrator try connecting your BEA server and wait for the error to appear.
6) Stop capture
7) Save captured data to a file (File->Save)
8) Send the file to support (at) ldapadministrator dot com
Support
 
Posts: 886
Joined: Sun Aug 12, 2001 12:00 am

Re: Error loading RootDSE entry from 10.162.3.155:7001.

Postby kcepull » Tue Aug 30, 2011 2:30 pm

Has a fix for this been found? I am having the exact same problem using LDAP Browser v4.5 against WebLogic Server v10.3.5.0. I can use other LDAP tools just fine (e.g. jXplorer), so it appears to be a problem with LDAP Browser itself.

Thanks,
Karl
kcepull
 
Posts: 1
Joined: Tue Aug 30, 2011 2:28 pm


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 1 guest

cron