userpassword

Beta testers only forum

Moderator: Support

userpassword

Postby Zoblin » Wed Oct 01, 2003 1:04 pm

Unfortunately, this is accidental bug. It appears during password modifying. Server logs it like this:
[01/Oct/2003:15:32:48 +0300] conn=82908 op=53 MOD dn="uid=APetrov,ou=People,o=company.com", invalid password syntax

And another one. Attribute passwordHistory contains several old password hashs. But it's displayed like a binary attribute. Why?
Zoblin
 
Posts: 38
Joined: Wed Sep 24, 2003 11:03 am
Location: Kiev, Ukraine

Re: userpassword

Postby Zoblin » Wed Oct 01, 2003 1:07 pm

After modifying password I need to click Refresh to make it display not plain text but hash. I consider, that's not right.
Zoblin
 
Posts: 38
Joined: Wed Sep 24, 2003 11:03 am
Location: Kiev, Ukraine

Postby Support » Thu Oct 02, 2003 7:49 am

Could you please provide a step-by-step scenario how to reproduce the issue.
Support
 
Posts: 895
Joined: Sun Aug 12, 2001 12:00 am

Postby Zoblin » Mon Oct 06, 2003 7:14 am

Support wrote:Could you please provide a step-by-step scenario how to reproduce the issue.

1. Right-click on the userpassword entry.
2. Type new value.
3. Enter.

I've sent screenshot to support@softerra.com.
Zoblin
 
Posts: 38
Joined: Wed Sep 24, 2003 11:03 am
Location: Kiev, Ukraine

Postby Support » Mon Oct 06, 2003 8:15 am

After modifying password I need to click Refresh to make it display not plain text but hash. I consider, that's not right.


Confirmed as a bug.

conn=82908 op=53 MOD dn="uid=APetrov,ou=People,o=company.com", invalid password syntax


We asked you about scenario for this issue.

Attribute passwordHistory contains several old password hashs. But it's displayed like a binary attribute. Why?


There are two possible reasons for this:

- The passwordHistory attribute belongs to an RFC2252 attribute syntax that is marked as not human readable.
- A value of the passwordHistory contains one or more non-printable symblo l or is not a valid UTF-8 string.
Last edited by Support on Thu Oct 09, 2003 8:47 am, edited 1 time in total.
Support
 
Posts: 895
Joined: Sun Aug 12, 2001 12:00 am

Postby Zoblin » Mon Oct 06, 2003 8:52 am

Support wrote:We asked you about scenario for this issue.

It occures accidentally :-? Maybe it is concerned with my local password policy (password length, password history and so on), I'm not sure.
Zoblin
 
Posts: 38
Joined: Wed Sep 24, 2003 11:03 am
Location: Kiev, Ukraine


Return to Beta Tester's Forum

Who is online

Users browsing this forum: No registered users and 0 guests

cron